Cisco WLC(Wireless LAN Controller)
20121215

概要
 なかなかぐぐっても出てこないWLCの細かな設定をメモとして記す
 ページ的にかなり見づらいのはそのうち修正予定

確認環境
 機種 CT5508、CT2504
 IOS 7.0.220〜7.3.xx(20121210迄のVersion)
〜ブートメニューについて〜
■ブートメニューの開き方
 コンソールケーブルを繋いでターミナルソフトを起動し、電源投入
 下記メッセージが出るのでESCキー連打しておきます。

Press now to access the Boot Menu...

============================================================
Boot Loader Menu
============================================================

1. Run primary image (7.0.235.0) - Active
→一番最後に入れたIOS。
→ActiveのIOSは、デフォルトで起動するIOSを指します。

2. Run backup image (7.3.101.0)
→1世代前までのIOSを保持しており、このブートメニューから起動する事が出来ます。

3. Change active boot image
→ActiveなIOSをprimaryとbackupとで入れ替えます。

4. Clear configuration
→Configの初期化を行います。工場出荷状態(起動時に初期ウィザードが出る状態)に戻します。
→WLCの初期化は通常この方法を用います。

5. Format FLASH Drive
→経験なし

6. Manually update images
→経験なし

アクションを起こすには、対応する数字を押してエンター
大抵は同意を求められるので、yを押してエンター
〜各種バージョンアップ〜
■用意するもの
 IOSやFirmwareのイメージファイル
  TFTPで転送出来るディレクトリに配置して下さい。
 上記ファイルを転送するためのTFTPサーバ
  サーバに関しては、3CDaemonなんかの簡易的なもので十分です。
 WLCとTFTPサーバが疎通出来るネットワーク環境

■まずはバージョン確認
(Cisco Controller) >show sysinfo

Product Version.................................. 7.0.235.0
→ロードされているIOSのバージョン

Bootloader Version............................... 1.0.1
→ブートローダのバージョン

Field Recovery Image Version..................... 6.0.182.0
→保持しているIOSが2つとも起動出来ない場合なんかに用いるレスキュー用IOSのバージョン

Firmware Version................................. FPGA 1.3, Env 1.6, USB console 1.27
→各種ファームウェアのバージョン

show sysinfoの一部のみ抜粋しております。

--------------------------------------------------------------------------------
■転送するにあたって、現在の設定状態を確認します。
(Cisco Controller) >transfer download start

Mode............................................. TFTP
→ダウンロード元のサーバータイプ。FTP等にも出来ます。

Data Type........................................ Code
→IOSやFirmwareの場合はこのままの設定で可
→Configurationだと設定のリストアになります。

TFTP Server IP................................... 0.0.0.0
→TFTPサーバのIPアドレス情報

TFTP Packet Timeout.............................. 6
→タイムアウトするまでの秒数

TFTP Max Retries................................. 10
→接続のリトライ回数

TFTP Path........................................
→TFTPサーバのディレクトリパス

TFTP Filename....................................
→ダウンロードするファイルの名前

This may take some time.
Are you sure you want to start? (y/N) n

何も設定されておりませんので、
nで抜けてください。

--------------------------------------------------------------------------------
■ダウンロード設定
(Cisco Controller) >transfer download serverip 192.168.0.3
→TFTPサーバのIPアドレスを指定

(Cisco Controller) >transfer download path /
→TFTPサーバの公開ディレクトリ直下にファイルを配置してる場合の設定

(Cisco Controller) >transfer download filename CT5500-K9-7-0-235-3.aes
→IOSのファイル名を指定

尚、この情報はConfigに保存される点に注意して下さい。
デフォルト(何もなし)にする場合は、アップデート後にCLIにて以下のコマンドを投入
→(Cisco Controller) >clear transfer

--------------------------------------------------------------------------------
■実際にアップデートを開始します。
(Cisco Controller) >transfer download start
Mode............................................. TFTP
Data Type........................................ Code
TFTP Server IP................................... 192.168.0.3
TFTP Packet Timeout.............................. 6
TFTP Max Retries................................. 10
TFTP Path........................................ /
TFTP Filename.................................... CT5500-K9-7-0-235-3.aes

This may take some time.
Are you sure you want to start? (y/N) y
→yを押してダウンロード開始

TFTP Code transfer starting.

.....

中略

TFTP File transfer is successful.
Reboot the controller for update to complete.
Optionally, pre-download the image to APs before rebooting to reduce network downtime.

--------------------------------------------------------------------------------
■問題なく完了している事を確認し、再起動します。
(Cisco Controller) >reset system
The system has unsaved changes.
Would you like to save them now? (y/N) y

--------------------------------------------------------------------------------
■起動後のVersion確認
(Cisco Controller) >show sysinfo
Product Version.................................. 7.0.235.3
Bootloader Version............................... 1.0.1
Field Recovery Image Version..................... 6.0.182.0
Firmware Version................................. FPGA 1.3, Env 1.6, USB console 1.27

Firmwareをアップデートする場合も同様の手順で可能です。
最近のWLCでは、Bootloader Version,Field Recovery Image Version,FPGA,Env,USB consoleが
一気にアップデートされます。
IOSと違い、Firmwareのアップデートに失敗すると立ち上がらなくなる場合がありますので、
十分注意して設定して下さい。
〜CT2504の特殊設定〜
■発生する事象について
 CT2504は4つのGigabitポートで構成され、2つのポートをPOEとして動作することが出来ます。
 (但し、POE使用はメーカー非推奨)
 CT5508には存在するサービスポートはありません。
 従い、APやPCのIPアドレスをCT2504のマネージメントセグメントへ設定し、
 物理的にもCT2504に直結にして設定構築することも多々発生します。
 しかし、以下のようにAPは正常に繋がってもPCは繋がらないといった現象が発生します。

 CT2504−AP OK
 CT2504−PC NG

ここで、以下のように間にL2SWでも挟めば解決するだろうと試みるのではないでしょうか。
(L3SWでも構いません)

 CT2504−AP OK
 CT2504−PC NG
 CT2504−SW−AP OK
 CT2504−SW−PC NG

しかし結果は変わりません。
--------------------------------------------------------------------------------
SW設定
interface FastEthernet0/1 ←SW〜AP間接続ポート
switchport access vlan 123 ←WLCの管理セグメント
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8 ←SW〜PC間接続ポート
switchport access vlan 123 ←WLCの管理セグメント
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/1 ←CT2504〜SW間接続ポート
switchport mode trunk
spanning-tree portfast
--------------------------------------------------------------------------------

■解決方法その@

そもそもタグ付きVLANを止める。

 初期ウィザードでは以下の設定を0にする
 →Management Interface VLAN Identifier (0 = untagged): 0

 構築済みの場合、CLIで以下のコマンドを投入
 →(Cisco Controller) >config interface vlan management 0

 CT2504−AP OK
 CT2504−PC OK
 CT2504−SW−AP OK
 CT2504−SW−PC OK

機能検証をする時はいいですが、根本的解決にはなってません。

■解決方法そのA

SW側にて、CT2504〜SW間ポートの設定を変更する。

 CT2504−AP OK
 CT2504−PC NG ←対策設定したSWを介さないため
 CT2504−SW−AP OK
 CT2504−SW−PC OK
--------------------------------------------------------------------------------
SW設定
interface FastEthernet0/1 ←SW〜AP間接続ポート
switchport access vlan 123 ←WLCの管理セグメント
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8 ←CT2504〜PC間接続ポート
switchport access vlan 123 ←WLCの管理セグメント
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/1 ←CT2504〜SW間接続ポート
switchport mode trunk
switchport nonegotiate
spanning-tree portfast
--------------------------------------------------------------------------------

赤文字部分を追加
根本解決をするにはこの方法を選択して下さい。

以上