Cisco StackWise
20130720

概要
 複数のSWを一つのSWとして構成出来る
 冗長化というよりは、合体?として構成される事が多いです。
 IOSのバージョンは同一にする必要有り
 同一機種でのポート数の相違は可

メリット
 ダウン時間の短い冗長構成を組むことが可能
 1つのホスト(論理的なSW)の物理ポートを増加させる事が可能

デメリット
 コストが増える。
 リンク間の冗長性を確保するには複数のポートを使用する必要がある。

今回使用する構成
 IOS 15.0(1)SE3
 機種 WS-C3750X-24(+4ポートがSFP)
     WS-C3750X-12(全SFP)
 マスター機プライオリティ  10
       スイッチナンバー 1
 メンバー機プライオリティ  5
       スイッチナンバー 2
◆SWをまずは別々に起動する
Switch#show post
Switch#show env all
Switch#show ver

Switch#show post
Switch#show env all
Switch#show ver
→エラーが無いか一応確認
マスターとなるホストでの設定
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#switch 1 priority 10
Changing the Switch Priority of Switch Number 1 to 10
Do you want to continue?[confirm]
New Priority has been set successfully

→スイッチナンバーはデフォルトが1な為、そのまま使用します。
メンバーとなるホストでの設定
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#switch 1 priority 5
Changing the Switch Priority of Switch Number 1 to 5
Do you want to continue?[confirm]
New Priority has been set successfully
→まずはデフォルトのスイッチナンバー1で設定します。

Switch(config)#switch 1 renumber 2
WARNING: Changing the switch number may result in a
configuration change for that switch.
The interface configuration associated with the old switch
number will remain as a provisioned configuration.
Do you want to continue?[confirm]
Changing Switch Number 1 to Switch Number 2
New Switch Number will be effective after next reboot
→このタイミングでデフォルトのスイッチナンバー1から2へ変更しています。
◆電源を切った上、物理的に接続
マスター機のスタックポート1とメンバー機のスタックポート2を接続
マスター機のスタックポート2とメンバー機のスタックポート1を接続

現行のCatalyst2960のケーブルは扱いやすい。
Catalyst3750のは扱いにくい。

電源ON時でも構いませんが、トラブル防止の為、電源OFFで作業します。
◆起動後確認

Switch#show switch detail
Switch/Stack Mac Address : xxxx.xxxx.xxxx
H/W Current
Switch# Role Mac Address Priority Version State
----------------------------------------------------------
*1 Master xxxx.xxxx.xxxx 10 1 Ready
2 Member xxxx.xxxx.xxxx 5 1 Ready


Stack Port Status Neighbors
Port 1 Port 2 Port 1 Port 2
--------------------------------------------------------
1 Ok Ok 2 2
2 Ok Ok 1 1

→スイッチナンバー1Masterであること。
→Current Stateが両方Readyであること。
→ポート状態がOkと相手ポートであること。(DownとNoneでないこと)
◆切り替え時間を短くする
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#stack-mac persistent timer 0
→Stack MACアドレスを無期限に使用する云々
 基本的にはこのコマンドを入れておいてください。
◆LANポートの状態について
Switch#show running-config
....
interface GigabitEthernet1/0/1
....
interface GigabitEthernet1/0/28
→ここまでがマスター機
....
interface GigabitEthernet2/0/1
....
interface GigabitEthernet2/0/12
メンバー機

※SFPポートが1/1/1と設定される機種では、以下のようになります。
 Gi1/1/1〜Gi1/1/4がマスター機
 Gi2/1/1〜Gi2/1/4がメンバー機

マスター機のシステムがダウンした場合、Gi1/0/1〜Gi1/0/28までのポート(リンク)が全ダウン。
メンバー機のシステムがダウンした場合、Gi2/0/1〜Gi1/0/12までのポート(リンク)が全ダウン。
以上の事から、アップリンクやSW間接続は通常Port-channel(LAG)にてリンクの冗長化を実施します。

参考例
interface Port-channel1
description ### To Core_SW ###
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
description ### To Core_SW GE1/0/47 ###
switchport trunk encapsulation dot1q
switchport mode trunk
udld port aggressive
channel-group 1 mode on
!
interface GigabitEthernet2/0/1
description ### To Core_SW GE1/0/48 ###
switchport trunk encapsulation dot1q
switchport mode trunk
udld port aggressive
channel-group 1 mode on
!
◆スタックケーブルを2本共に切り離した場合(1本では影響無し)
 マスター機
  interface GigabitEthernet2/0/1〜interface GigabitEthernet2/0/12が消失
  その他は変化なし
 メンバー機
  interface GigabitEthernet1/0/1〜interface GigabitEthernet1/0/12が消失
  1/0/1が無い不思議な単体機になります。その他は変化なし

◆完全に切り離したい場合はConfigの以下の部分をno付けて消去する。
  マスター機が独立するためには相手情報にno付けて消去する。
   Switch#conf t
   Enter configuration commands, one per line. End with CNTL/Z.
   Switch(config)#no switch 2 provision ws-c3750x-12

  メンバー機が独立する場合は相手情報にno付けて消去する。
   Switch#conf t
   Enter configuration commands, one per line. End with CNTL/Z.
   Switch(config)#no switch 1 provision ws-c3750x-24
  →インターフェースが通常のGi1/0/1に戻ります。

以上