CiscoルーターによるPPPoE+PAT
20131001

環境
 確認機種 : Cisco 851
       Cisco 892
 IOS : 12.4(6)T
    15.2(4)M4
 複数のマシンを同時に外部ネットワークへ接続する為、NATタイプとしてPATを使用する。
 内部アドレス192.168.0.3を外部公開用WEBサーバーとして使用する。
 設定項目についてはCiscoルーターによるPPPoEとほぼ同一である。
注意事項
 ダイヤラーインターフェースの作成を行って、物理インターフェースと関連付ける必要があります。

 NTT西日本の「フレッツ・光プレミアム」の場合、以下の設定を行わないと正常に動作しません。
 関西地区の方はご注意ください。
  MTUを1438
  MSSを1398

 今回は関西地区の設定で行っております。
 「フレッツ・光プレミアム」以外の方は以下の設定を参照
  MTUを1454
  MSSを1414
具体的なコンフィグは以下の通り

interface FastEthernet4
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
interface Dialer0
mtu 1438
ip address negotiated
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1398
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ユーザ名
ppp chap password 0 パスワード
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip nat inside source static tcp 192.168.0.3 80 interface Dialer0 80
ip nat inside source list 99 interface Dialer0 overload
access-list 99 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
#WAN側interface
#全二重/半二重 設定不要
#インターフェースの速度タイプの指定 設定不要
#PPPoEセッションをいねーぶる
#関連付けるDialerのプールナンバーの指定

#LAN側interface若しくはVLAN
#VLANのネットワーク
#NATの内部interfaceと指定

#Dialer interface
#MTUの指定(「フレッツ・光プレミアム」以外の方は1454)
#IPネゴシエートと設定
#NATの外部interfaceと指定
#L2プロトコルをPPPに指定
#MSSの指定(「フレッツ・光プレミアム」以外の方は1414)
#dialer pool number
#自動切断防止
#dialer-listの適用
#CDPの無効
#PPP認証をCHAPに設定
#認証時のユーザー名指定
#認証時のパスワード指定

#デフォルトゲートウェイを指定
#ポート80(www)を192.168.0.3に紐付ける。いわゆる静的マスカレード
#PATの設定
#アドレスプール
#IPパケットが云たら

最後に
 セキュリティを考え、ポート80以外を通過しないACLの適用及びCBACの実装を推奨します。

 詳しくは以下参照
  Access Control List
  ContextBased Access Control